PHP-Z

编程

Nginx 1.11.7 主线版本发布

2016-12-14 09:36 发布者: 大熊猫

Nginx-1.11.7主线版本刚发布了。该版本的更新如下:

变更: 

  • 当出现客户端证书验证失败时,$ssl_client_verify 变量会记录失败的原因, 例如:"FAILED:certificate has expired".

新特性: 

  • 新增 $ssl_ciphers, $ssl_curves, $ssl_client_v_start, $ssl_client_v_end, and $ssl_client_v_remain 这几个变量.

  • "map" 指令支持 "volatile" 参数.

bug 修复: 

  • 当构建动态(.so/.dll)模块时,模块的特定依赖将被忽略.

  •  当使用HTTP/2模块和 ("limit_req" 或 "auth_request")指令时,可能会出现客户端请求体不完整的问题;该BUG在1.11.0版本开始出现。

  • 当使用HTTP/2模块时,工作进程中可能会出现段错误,该BUG在1.11.3版本开始出现。

  • ngx_http_mp4_module模块。

  • ngx_http_perl_module模块。

下载地址:

源代码:http://nginx.org/download/nginx-1.11.7.tar.gz

Windows可执行文件:http://nginx.org/download/nginx-1.11.7.zip

关注微信公众号

top100summit

扫一扫关注微信公众号

PHP-Z_COM